Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input

1
2
3
4
5
6
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output

1
2
3
4
5
YES
NO
NO
YES
NO

代码实现

C语言

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
#include<stdio.h>

int main() {
// Max堆栈已压入的最大值,Push、Pop标记压入和取出次数
int M, N, K, Max, Push, Pop;

scanf("%d %d %d", &M, &N, &K);
int A[N]; // C99
for ( int i=0; i<K; i++ ) { // 有K个序列需要检查
Max = Push = Pop = 0;
for ( int j=0; j<N; j++ ) { // 保存序列到数组
scanf("%d", &A[j]);
}
for ( int m=0; m<N; m++ ) { // 遍历每个数组
if ( A[m] > Max ) { // 如果读取的数大于记录的最大值,则堆栈中有数字压入
Push += A[m] - Max; // 更新压入的次数
if ( Push - Pop <= M ) { // 压入后堆栈中的数不能大于堆栈能容纳的最大值
Pop++; // 更新取出次数
Max = A[m]; // 更新已压入最大数
} else {
break;
}
} else if ( A[m] < Max ) { // 如果读取的数小于最大值,则堆栈处于取出状态
if ( A[m] < A[m-1] ) { // 处于取出状态时,因为从小到大压入,所以后一个取出的数字一定小于前一个
Pop++;
} else {
break;
}
}
}
if ( Push == Pop && Pop == N ) { // 如果记录的push和pop次数相等,并且等于数字个数,则该序列可输出
printf("YES\n");
} else {
printf("NO\n");
}
}

return 0;
}